postponeTime not working

3 posts / 0 new
Last post
#1 Wed, 8 Feb 2017 14:32
Anonymous (not verified)

postponeTime not working

Hi, i need to send faxes via REST Fax API. I'm using a php script and when I run it everything works, however the fax is sent immediately even if i set the postponeTime parameter with the format indicated here https://www.interfax.net/en/dev/rest/reference/2927.

Wed, 8 Feb 2017 22:20
Eyal N

Hi Zek,
I am sorry for the confusion. When sending the postpone time value in a REST request, you will need to urlEncode the postpone time component of the URL.
When using a timezone that is earlier than GMT, which would require you to provide the '+' sign, you will need to convert the '+' to %2B for the REST API to identify it properly.

When reviewing your faxes, I saw that you were trying to send the fax with a postpone time for March 5th, 2017 at 15:52:01 GMT+1. The format of this is, as you wrote it,

2017-03-05T15:52:01+01:00

. When you urlEncode this component, it will become

2017-03-05T15%3A52%3A01%2B01%3A00

.

If you use this value, the fax will be postponed to the time and date requested.

We have also corrected the documentation to include a specification that the postpone time component should be urlEncoded.

Thu, 9 Feb 2017 11:12
Zek (not verified)

Thank You for the clarification.

Log in or register to post comments

Contact us today

Talk to a member of our team about the benefits InterFAX can bring to your organization's communications processes.

Contact us today