Discontinuing support of IE 8 and older versions

Interfax is dropping support for Internet Explorer 8 and older versions of Internet Explorer. The changes, which take effect from June 01, 2015, are meant to enable you to have the best experience possible, while also freeing up much of our time to better support product development.

We recommend using the most up-to-date version of any of the following browsers:

  • Google Chrome
  • Mozilla Firefox
  • Internet Explorer (9 and up) for Windows

We've traditionally taken a conservative approach to browser support: We don't want to be the forcing factor on any of your own browser support decisions. But the make-up of the web has changed and is now made up of a much more diverse array of physical devices. This is our reasoning for dropping support for Internet Explorer 8 and below.

From June 01, 2015, when users log on to the InterFAX (Secure) site using an unsupported browser, a popup window will appear indicating that a browser version update is required. Likewise, when users attempt to open the Fax Viewer (in order to see a fax document from the inbound queue) a similar popup message will appear.

Please contact us if you have any questions or concerns.

Contact us today

Talk to a member of our team about the benefits InterFAX can bring to your organization's communications processes.

Contact us today