TLS 1.0 - End of Life!

In keeping with PCI DSS requirements, it is mandatory to upgrade from TLS 1.0 to TLS 1.1 or higher, before June 01, 2018. If you need to make the change, we recommend you move to the latest version available to get the most from your efforts.

For more information on the issue, see this reference.

The PCI Data Security Standard 3.1 recommends disabling "early TLS" along with SSL: SSL and early TLS are not considered strong cryptography and cannot be used as a security control after June, 2018.

The best response is to disable SSL entirely and migrate to a more modern encryption protocol, which at the time of publication is a minimum of TLS v1.1, although entities are strongly encouraged to consider TLS v1.2.

We are working on a site that will support developers to test the change. We will update you as soon as the test site is ready.